Close
Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 54
Like Tree4Likes

Thread: Galaxy s4 i9500 screen flicker issue

  1. #11
    Junior Member muddi's Avatar
    Join Date
    Oct 2013
    Posts
    2
    Member #
    5595
    Device
    GT-I9500
    Mentioned
    0 Post(s)
    ACTUALLY,its just a flash...comes in any app..say if i am composing a msg...the screen would flash and the keyboard may disappear...if it happens while m playing a game,the game shall pause...

    NOW,since the flash is very very brief like some less than even a second...so in video it might not be appreciable but wat i see is a clock,very similar to wat it wud hv been wen a S VIEW cover is in place,i am not using the s-view cover though but it appers exactly same,.....hope u got me??

  2.  

  3. #12
    Junior Member shaur's Avatar
    Join Date
    Oct 2013
    Posts
    1
    Member #
    5599
    Mentioned
    0 Post(s)
    I have the same problem. Very frustrating. Anyone can help??? Much appreciated. Thanks

  4. #13
    Junior Member joe01880's Avatar
    Join Date
    Oct 2013
    Posts
    11
    Member #
    5515
    Liked
    2 times
    Mentioned
    0 Post(s)
    Try turning off auto brightness, see if that helps.

  5. #14
    Junior Member yatiya's Avatar
    Join Date
    Nov 2013
    Posts
    2
    Member #
    6023
    Device
    GT-I9500
    Mentioned
    0 Post(s)
    Quote Originally Posted by joe01880 View Post
    Try turning off auto brightness, see if that helps.
    I have exactly the same problem. It has nothing to do with auto-brightness. Even though a *#0*# self test reports all the sensors as working, I suspect the magnetic sensor near the volume rocker is faulty. I've given it in to a Samsung repair centre, but I hope they don't return it with a "Sorry, there's nothing wrong" message!

  6. #15
    Junior Member cmccarthy's Avatar
    Join Date
    Nov 2013
    Posts
    1
    Member #
    6111
    Device
    GT-I9500
    Mentioned
    0 Post(s)
    I have been having the screen flicker going to black clock problem on the S4 now for 2 months. After doing a factory restore and nothing installed or setup on the phone I did some tests. It happens only when there is 4 bars or less on the Vodacom GSM/Edge network. It does not happen on 3G, HSDPA or LTE. Setting the phone to WCDMA fixes the problem but I travel to places where there is only GSM/Edge signal. Funny if I swop from Vodacom to another provider the problem goes away. I would really love a permanent fix for this.
    Last edited by cmccarthy; 11-07-2013 at 12:08 PM.

  7. #16
    Junior Member yatiya's Avatar
    Join Date
    Nov 2013
    Posts
    2
    Member #
    6023
    Device
    GT-I9500
    Mentioned
    0 Post(s)
    Quote Originally Posted by cmccarthy View Post
    I have been having the screen flicker going to black clock problem on the S4 now for 2 months. After doing a factory restore and nothing installed or setup on the phone I did some tests. It happens only when there is 4 bars or less on the Vodacom GSM/Edge network. It does not happen on 3G, HSDPA or LTE. Setting the phone to WCDMA fixes the problem but I travel to places where there is only GSM/Edge signal. Funny if I swop from Vodacom to another provider the problem goes away. I would really love a permanent fix for this.
    Thanks for that. Very interesting. I never checked on mine whether it was network related, as I assumed a hardware fault unrelated to network. Nonetheless, it's at Samsung now "awaiting parts". Hopefully will be fixed when it gets back!

  8. #17
    Junior Member abhas7's Avatar
    Join Date
    Nov 2013
    Posts
    1
    Member #
    6183
    Device
    GT-I9500
    Mentioned
    0 Post(s)
    I am also experimenting lots of things with my s4, but i am only find that only during internet use, the s-view cover screenshot flickers randomly. Sometimes it may be various times in a minute & sometimes in a long gap. There is no any proper frequency that when it will happen. After visiting the servicing center last week, they didn't able to identify the problem.

    Shall any one help me how can i contact/mail to Samsung head office. I think any specific software update for this problem is the only solution.

    Any other help regarding this topic plz help & reply.

  9. #18
    Junior Member SeanAvery's Avatar
    Join Date
    Nov 2013
    Posts
    2
    Member #
    6242
    Device
    GT-I9500
    Liked
    1 times
    Mentioned
    0 Post(s)
    Howdy everyone,
    My S4 did the same - drove me nuts, especially while sending a message. try this - Go to Settings - My Device - Display - Brightness - Untick Automatic Brightness.
    THEN - Settings - Display - Scroll down to 2nd last item and untick - Auto adjust Screen tome.

    This worked for me.
    Cheers
    Sean
    sculptedstylus likes this.

  10. #19
    Junior Member canned's Avatar
    Join Date
    Nov 2013
    Posts
    1
    Member #
    6658
    Device
    GT-I9500
    Mentioned
    0 Post(s)
    Quote Originally Posted by yatiya View Post
    I have exactly the same problem. It has nothing to do with auto-brightness. Even though a *#0*# self test reports all the sensors as working, I suspect the magnetic sensor near the volume rocker is faulty. I've given it in to a Samsung repair centre, but I hope they don't return it with a "Sorry, there's nothing wrong" message!
    I do believe I found the problem. I have also been experiencing this issue and it was hella annoying. It just so happens it coincided with the time I got a new cover for the phone - not the type of cover with the window in front to display the time. BUT when my screen did flicker, I noticed it was the time that flashed up on the screen and in the area where that window would be (if i had such a cover). So when yatiya mentioned the magnetic sensor, i thought to remove the cover. since I've removed the cover I havent had the flicker - granted it was only 2 hours and 30 mins ago. My cover has Carbon Fibre in it. Another friend also had the flicker and his cover has metal in it. However, he also updates his phone as soon as an update is out, so his flickering went away with all the updating he's done - which leads me to believe that Samsung may have increased the tolerance in the algorithm for the magnetic sensor?? I think it is the cover causing the problem. I'm going to leave it off for a few days and see unless any of you know how to turn this "time in window" feature off?

  11. #20
    Junior Member shrads's Avatar
    Join Date
    Dec 2013
    Posts
    1
    Member #
    7398
    Device
    GT-I9500
    Mentioned
    0 Post(s)
    I am facing the same issue , screen goes black anytime i am playing games or typing on my phone, it is damn annoying :X got it checked on Samsung authorized service center today , they said they have tighten the screen connector which was loose, i am still facing the same issue (lol.. i am sure they couldn't trouble down the issue, and giving me fake analysis)...

    Now what to do next .. someone here knows the root cause and solution ??

Page 2 of 6 FirstFirst 1234 ... LastLast

Remove Ads

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Increasing volume of Galaxy S4 (GT-I9500)
    By Tanay in forum Galaxy S4 Audio
    Replies: 4
    Last Post: 09-30-2013, 05:45 AM
  2. Call drop & network issue in samsung galaxy s4 gt-i9500
    By arnab96 in forum Galaxy S4 General Discussion
    Replies: 2
    Last Post: 07-25-2013, 07:21 PM
  3. Internet Home screen shortcuts issue
    By jpatnorman77 in forum Galaxy S4 Apps
    Replies: 1
    Last Post: 06-01-2013, 10:53 PM

Search tags for this page

galaxy s4 flickering screen
,

galaxy s4 screen flicker

,

galaxy s4 screen flickering

,
s4 screen flicker
,
s4 screen flickering
,
samsung galaxy s4 flickering screen
,

samsung galaxy s4 screen flickering

,
samsung s4 flickering screen
,
samsung s4 screen flicker
,
samsung s4 screen flickering
Click on a term to search our site for related topics.

Tags for this Thread