Close
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member importsjc's Avatar
    Join Date
    Apr 2016
    Posts
    6
    Member #
    14774
    Device
    SCH-I545
    Mentioned
    0 Post(s)

    Question OK Google Not Working

    I recently changed phones to a S4 and I really like it! However I have one strange issue I can't figure out. I cannot use the "Ok Google" hotword in order to search.

    I have tried turning on the ok google from any screen option but I can't get the "Ok Google" trained since the hotword doesn't work! Also my google search bar (on my home screen and in google now) doesn't say "Say Ok Google" instead it says "Search..". I have tried restarting my phone and clearing the cache on both the Google app and the Google now launcher, with no results. Both apps are fully updated. I have also checked my language settings and they are fine.

    I read that the S Voice app can sometimes get in the way of the "Ok Google" hotword but it still doesn't work with S Voice disabled.

    Here is a list of my currently disabled apps: Amazon, Amazon kindle, Amazon Music, Appstore (amazon), Audible, Calendar, Cloud (verizon), Flipboard, Group Play, IMDb, KNOX, Polarix Office 5, S Beam, S Health, S Memo, S Voice, Samsung Print Service Plugin, Samsung WatchON, Story Album, Support and Protection (verizon), TripAdvisor, VZ Navigator, Yahoo! Finance, Yahoo! News.

    Please, if you can think of anything else, let me know! Your help is appreciated.

    - Stephen

  2.  

  3. #2
    Senior Member Leeshor's Avatar
    Join Date
    Mar 2013
    Location
    Norcoss, GA
    Posts
    3,968
    Member #
    21
    Device
    SGH-I337
    Liked
    1411 times
    Mentioned
    35 Post(s)
    Welcome to the forum

    Go to the app drawer and tap on the Google icon. Go to settings - voice and enable voice on any screen.
    Samsung Galaxy S 10.5 - SGH-i337 on AT&T - and LG G4

    Printing and file transfer tips
    WiFi connection tips. (modified 7/26/13)
    Current versions of Android don't support Flash player, try Puffin or Flashfox as an alternative browser.

  4. #3
    Junior Member importsjc's Avatar
    Join Date
    Apr 2016
    Posts
    6
    Member #
    14774
    Device
    SCH-I545
    Mentioned
    0 Post(s)
    Quote Originally Posted by Leeshor View Post
    Welcome to the forum

    Go to the app drawer and tap on the Google icon. Go to settings - voice and enable voice on any screen.
    Thanks for the response! Like I said above I have already tried that.

    I have tried turning on the ok google from any screen option but I can't get the "Ok Google" trained since the hotword doesn't work!

  5. #4
    Senior Member Leeshor's Avatar
    Join Date
    Mar 2013
    Location
    Norcoss, GA
    Posts
    3,968
    Member #
    21
    Device
    SGH-I337
    Liked
    1411 times
    Mentioned
    35 Post(s)
    Restart and try again.
    Samsung Galaxy S 10.5 - SGH-i337 on AT&T - and LG G4

    Printing and file transfer tips
    WiFi connection tips. (modified 7/26/13)
    Current versions of Android don't support Flash player, try Puffin or Flashfox as an alternative browser.

  6. #5
    Junior Member importsjc's Avatar
    Join Date
    Apr 2016
    Posts
    6
    Member #
    14774
    Device
    SCH-I545
    Mentioned
    0 Post(s)
    Quote Originally Posted by Leeshor View Post
    Restart and try again.
    I have restarted but there is no change in behavior.

  7. #6
    Senior Member Leeshor's Avatar
    Join Date
    Mar 2013
    Location
    Norcoss, GA
    Posts
    3,968
    Member #
    21
    Device
    SGH-I337
    Liked
    1411 times
    Mentioned
    35 Post(s)
    Go to the app manager, scroll to all and find the Google Services Framework. Clear the data, force stop and restart the phone. If that doesn't work remove your Google account, restart and add it back again.
    Samsung Galaxy S 10.5 - SGH-i337 on AT&T - and LG G4

    Printing and file transfer tips
    WiFi connection tips. (modified 7/26/13)
    Current versions of Android don't support Flash player, try Puffin or Flashfox as an alternative browser.

  8. #7
    Junior Member importsjc's Avatar
    Join Date
    Apr 2016
    Posts
    6
    Member #
    14774
    Device
    SCH-I545
    Mentioned
    0 Post(s)
    Quote Originally Posted by Leeshor View Post
    Go to the app manager, scroll to all and find the Google Services Framework. Clear the data, force stop and restart the phone. If that doesn't work remove your Google account, restart and add it back again.
    Done and done. Unfortunately there is still no change!

    Thanks for the help!

  9. #8
    cr6
    cr6 is offline
    Administrator cr6's Avatar
    Join Date
    Mar 2013
    Posts
    1,262
    Member #
    17
    Device
    other
    Liked
    504 times
    Mentioned
    8 Post(s)
    Re-enable S Voice (but don't turn it on), restart your device and try again. Make sure all of your ok Google detection options are turned on. and then go into accounts & make sure voice and audio activity is enabled.
    Also make sure speech output it's set to "on" and not hands free only.

    I'm pretty sure it's because you have S Voice disabled. I'm not sure where you read that, but it won't interfere with your Ok Google option.

  10. #9
    Junior Member importsjc's Avatar
    Join Date
    Apr 2016
    Posts
    6
    Member #
    14774
    Device
    SCH-I545
    Mentioned
    0 Post(s)
    I have re-enabled S-Voice and restarted but the issue is still present. I have the "From the google app" options enabled but I cannot enable the bottom two because I can't get past the voice training step (since my phone won't recognize the "Ok Google" hot word). My speech options is also set to "on".

    I am not sure what you mean by "go into accounts & make sure voice and audio activity is enabled."

    In Settings>Language and Input>Voice Input I have "Enhanced Google services" enabled if that's what you were thinking.

  11. #10
    cr6
    cr6 is offline
    Administrator cr6's Avatar
    Join Date
    Mar 2013
    Posts
    1,262
    Member #
    17
    Device
    other
    Liked
    504 times
    Mentioned
    8 Post(s)
    Try going in and deleting your current Google voice model so you can retrain it.
    Also, under language & input, make sure Google voice typing is enabled then go into text to speech option, make sure Google text to speech is enabled, and not the Samsung text to speech. Reboot phone, retrain Google now voice model and see if that works. If none of these work, you may need to do a factory data reset. If everything is enabled and it's still not working, this may be your only option.
    OR, try re-enabling every app you've disabled to see if by chance something there was keeping this from working. This is the chance we take by disabling system apps as many of them are interconnected.
    Good luck!

    S5 tap'n

Page 1 of 2 12 LastLast

Remove Ads

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Mobile internet not working (WIFI is working fine)
    By Tjulani in forum Galaxy S4 Help
    Replies: 8
    Last Post: 01-03-2014, 03:13 PM
  2. Replies: 1
    Last Post: 07-25-2013, 10:42 AM
  3. Replies: 11
    Last Post: 05-29-2013, 06:12 PM
  4. Replies: 0
    Last Post: 05-16-2013, 10:31 AM
  5. Replies: 1
    Last Post: 03-14-2013, 12:57 PM

Search tags for this page

how to retrain okay google galaxy s4

Click on a term to search our site for related topics.

Tags for this Thread