Close
Results 1 to 3 of 3
  1. #1
    Junior Member kutu62's Avatar
    Join Date
    Jul 2016
    Posts
    2
    Member #
    14970
    Device
    SCH-R970
    Mentioned
    0 Post(s)

    New Charge Port Version Issue S4 SCH-R970C

    The charge port for my S4 is going out so I purchase a new one - exact same model number but a different revision, since I purchase a "up rev" I figured I'd be good.. no mas..

    Current Charge Port = SCH-R970C Ver. 02
    Ones I've found for sell = SCH-R970C Ver. 03

    Ver .03 doesn't work on my phone.. is there anything I can update/change to get version .03 board to work?

    Additional Info: with the ver .03 board the phone will boot, but the charge cable is only recognized when the phone is powered off - however it still doesn't charge -

    Thank you!

  2.  

  3. #2
    Senior Member Leeshor's Avatar
    Join Date
    Mar 2013
    Location
    Norcoss, GA
    Posts
    3,968
    Member #
    21
    Device
    SGH-I337
    Liked
    1411 times
    Mentioned
    35 Post(s)
    Welcome to the forum

    All I can say is YIKES. I would have thought the same as you
    Samsung Galaxy S 10.5 - SGH-i337 on AT&T - and LG G4

    Printing and file transfer tips
    WiFi connection tips. (modified 7/26/13)
    Current versions of Android don't support Flash player, try Puffin or Flashfox as an alternative browser.

  4. #3
    Junior Member kutu62's Avatar
    Join Date
    Jul 2016
    Posts
    2
    Member #
    14970
    Device
    SCH-R970
    Mentioned
    0 Post(s)
    Quote Originally Posted by Leeshor View Post
    Welcome to the forum
    All I can say is YIKES. I would have thought the same as you
    I contacted the ebay person that sold it to me and they are sending me a new board, rev.02 - good stuff!

Remove Ads

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. USB Port Problem
    By Sestmak in forum Galaxy S4 Help
    Replies: 3
    Last Post: 07-21-2015, 09:56 PM
  2. Cleaning the mucro USB port
    By ras in forum Galaxy S4 Help
    Replies: 3
    Last Post: 01-28-2014, 12:22 PM
  3. Charge port question
    By RonRock in forum Galaxy S4 General Discussion
    Replies: 3
    Last Post: 01-04-2014, 11:11 AM
  4. A download issue, Hardware issue, or is it a WIFI issue?
    By n0m0n in forum Galaxy S4 General Discussion
    Replies: 60
    Last Post: 08-09-2013, 12:54 PM

Search tags for this page

There are currently no search engine referrals.
Click on a term to search our site for related topics.

Tags for this Thread